• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Subwoofer not working in AV

Sandip@8096

New Member
Joined
Jul 1, 2019
Messages
1
Points
1
Location
Kochi
Hello everyone,
I need help to correct my subwoofer.
I am having marantz 1504 receiver and Boston soundware 5.1 satellite speakers. IAM using this set for more than five years. Suddenly my subwoofer is stopped working. I have checked subwoofer cable by replacing then AV reset but nothing is working.
Subwoofer is showing green light, can anyone suggest what is the problem and how to resolve it.
 
SPONSORED ADS

SPONSORED ADS

efernand1

Well-Known Member
Joined
Jul 6, 2012
Messages
4,964
Points
113
Location
Mumbai
Hello everyone,
I need help to correct my subwoofer.
I am having marantz 1504 receiver and Boston soundware 5.1 satellite speakers. IAM using this set for more than five years. Suddenly my subwoofer is stopped working. I have checked subwoofer cable by replacing then AV reset but nothing is working.
Subwoofer is showing green light, can anyone suggest what is the problem and how to resolve it.
It could be a dry solder issue.......if there is a skillful electrician / repairer around who services Hifi Systems and LCD TVs, it can be resolved. Issue could be on the output circuit. Could be speaker wire is disconnected inside.....
 

MaSh

Well-Known Member
Joined
Oct 12, 2012
Messages
2,624
Points
113
Location
Bangalore
Check the fuse. Had seen this long back in a polk sub. A small IC needed to be replaced and it was back

MaSh
 
SPONSORED ADS

Top