Fuse for Audio-Technica AT-LP140XP

douglasartor

New Member
Joined
Aug 2, 2022
Messages
1
Points
1
Location
Porto Alegre, Br
Hi guys, does anyone can tell which is the main fuse for Audio-Technica AT-LP140XP? I've bought from a bargain site from someone that turn it back to the store. The store said it was in "perfect" condition. The only problem is that it doesn't turn on (LOL). I've opened its back and realized that the fuse was worn. So I change it, but it burned again I few seconds later. I changed a 250V7A fuse for a 250V10A fuse. It should work, but think there is something odd with this fuse... Can anyone help me? Thanks!
 

sdk

Active Member
Joined
Sep 28, 2014
Messages
250
Points
43
Location
Mumbai
Hi guys, does anyone can tell which is the main fuse for Audio-Technica AT-LP140XP? I've bought from a bargain site from someone that turn it back to the store. The store said it was in "perfect" condition. The only problem is that it doesn't turn on (LOL). I've opened its back and realized that the fuse was worn. So I change it, but it burned again I few seconds later. I changed a 250V7A fuse for a 250V10A fuse. It should work, but think there is something odd with this fuse... Can anyone help me? Thanks!
From what little I know, the fuse blew because of a fault further down in the circuit

Just replacing a blown fuse without finding the fault is dangerous.

Replacing with a higher rating of 10A instead of the original 7A is even more dangerous and you could cause a fire.

Either have it looked at by a technician or junk it if repairs are too expensive

Edit:
The specs online says that it's power consumption is only 6W, why would it require 7 or 10A fuse?
 

Attachments

  • Screenshot_20220802_220041.jpg
    Screenshot_20220802_220041.jpg
    339.7 KB · Views: 1
Last edited:
Join group to get HiFiMART.com Offers & Deals on WhatsApp
Top