• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

TV & Home theater & STB connection problem

Mogami Cables

kav4

New Member
Joined
Jun 8, 2014
Messages
8
Points
0
Location
Sri Lanka
I am having Samsung 55" H6400 (series 6) Smart TV with Samsung SMGHTH5550 Home theater system. Also having a Videocon STB (STB2233) with Dolby Digital.

STB does not have a Digital out (optical). It has only a SPDIF out. I have added a box which convert SPDIF out to Digital optical out & connected it to the Home theater. This Digital out & TV's Digital out both connect to the HT's Digital in through a (2 input & one output) box.

HT is connected to the HDMI (ARC) port on the TV & the STB is connected to the HDMI (STB) port of the TV.

Both TV & the HT is connected to the router via WiFi.

In TV's Speaker out there are 5 options available.
TV Speaker
Audio Out
Receiver
SoundShare
Multiroom Link

Earler the "Receiver" option was available & I could change the volume of the HT through the TV's remote. Now suddenly that option is un-selectable & only TV Speaker & Audio Out is available. How can I get the Receiver option back? (Anynet+ (HDMI-CEC) is enabled on both TV & HT)

Also the STB Dolby Digital channels can be heard only from front speakers of the HT. On HT under Audio there's an option with Digital output heading. It has 4 options
PCM
Bitstream (Unprocessed)
Bitstream (Re-encoded DTS)
Bitstream (Re-encoded Dolby D)

Sound comes from all speakers only if I select PCM from here. Why is that.

Please help me on this as I'm a newbie to this.

Thanks in advance.

(manual for the HT)
 
SPONSORED ADS

SPONSORED ADS

moshel

New Member
Joined
Mar 8, 2009
Messages
70
Points
0
Location
Ahmedabad
Remove all connections and start from the top with this:

1. Connect STB to TV via HDMI
2. Connect STB (SPDIF out) to HT (Coaxial/Optical In)

On the HT select the proper input mode (it should be written just above or below the Coaxial/Optical In connector). I have an onkyo and in it against each input mode (BD/DVD, TV, Game, etc.) I can select the audio source (HDMI, Coaxial/optical, RCA etc.). Make sure you check this.

The sound is coming to your HT either from the STB or the TV since you have ARC and it is already decoded. The HT outputs this sound directly without processing, hence it shows up PCM.

Check the above options and revert if you face further issues.
 
SPONSORED ADS

Top