1909 and HD 870 issues

shuv

Active Member
Joined
Sep 9, 2009
Messages
723
Points
43
Location
Calcutta
@ Mods - Not sure where to post this thread. Please move to appropriate section if required.

I have my Sammy HD 870 DVDp connected to my 1909 with HDMI cable. Everything was ship shape till last week.

Now, when I play my Reg. 1 DVDs the screen goes green (Sammy LCD) and the audio is intermittent. The AVR display shows its being fed a DD signal. The screen fluctuates between green and black, no pictures. Even when I stop playback, the Sammy screen doesn't appear until I power the 870 off and then on again. My backup DVDs (Reg Free) are working fine though. I tried resetting the 870 and doing the Reg Free soft hack. No joy:sad:

Please :sos:

P.S backups are ripped with DVDShrink/DVDFAB
 
Last edited:
@ Mods - Not sure where to post this thread. Please move to appropriate section if required.

I have my Sammy HD 870 DVDp connected to my 1909 with HDMI cable. Everything was ship shape till last week.

Now, when I play my Reg. 1 DVDs the screen goes green (Sammy LCD) and the audio is intermittent. The AVR display shows its being fed a DD signal. The screen fluctuates between green and black, no pictures. Even when I stop playback, the Sammy screen doesn't appear until I power the 870 off and then on again. My backup DVDs (Reg Free) are working fine though. I tried resetting the 870 and doing the Reg Free soft hack. No joy:sad:

Please :sos:

P.S backups are ripped with DVDShrink/DVDFAB
Strange. Do some basic cross-checks though.

- Could it be a colour system setting in the DVDP? Is it set to Auto or specifically to something else?
- Also check if progressive scan is on.

Buy a new DVDP ;)
 
Problem still persists. I tried resetting the AVR but no results. I don't think its an AVR problem. Connected the DVDp with the TV via HDMI and same results.:sad:
Please help guys!!
 
This is the problem with your DVD player due to Pal and NTSC selection in the setup menu of the player.The player doesn't have an auto selection option so everytime when you insert a Pal Disk you have to manually select the option in the player's setup Menu under the video settings first and then insert the disk.Same goes with NTSC too.
I know about this as I have faced a similar sort of problem when I intially bought My samsung DVD 1080P7 but now as I am familiar with this problem so I do the settings as I have written earlier to avoid it.
 
This is the problem with your DVD player due to Pal and NTSC selection in the setup menu of the player.The player doesn't have an auto selection option so everytime when you insert a Pal Disk you have to manually select the option in the player's setup Menu under the video settings first and then insert the disk.Same goes with NTSC too.
I know about this as I have faced a similar sort of problem when I intially bought My samsung DVD 1080P7 but now as I am familiar with this problem so I do the settings as I have written earlier to avoid it.


The setup used to work perfectly!! Never had to manually select PAL/NTSC before. But, now even if I select PAL/NTSC (based on the source) it refuses to play.:sad:
All copied DVDs are working fine though.
 
The setup used to work perfectly!! Never had to manually select PAL/NTSC before. But, now even if I select PAL/NTSC (based on the source) it refuses to play.:sad:
All copied DVDs are working fine though.

Copied Dvd work fine because they might not have such limitations whereas with the original dvds this problem exists. Its the fault of your dvd player try resetting your dvd player to factory default, also does the normal samsung screen come up when there is no dvd in the slot?
 
It can be HDMI cable prob too,try connecting seperate with vid,coax-sound & check with proper setting.
 
Copied Dvd work fine because they might not have such limitations whereas with the original dvds this problem exists. Its the fault of your dvd player try resetting your dvd player to factory default, also does the normal samsung screen come up when there is no dvd in the slot?

I did the factory reset on both the DVDp and the AVR. No change. The Sammy welcome screen comes up without a disc in the slot. When I put a disc in, the screen shows "LOADING" and then the problem starts. Sound comes and goes, display toggles between green and black. Its like green screen and sound (title menu of disc) for 5 seconds and then blank and no sound.

It can be HDMI cable prob too,try connecting seperate with vid,coax-sound & check with proper setting.

Tried this. Component video cables and optical. Same result.

Do I need to junk the DVDp? If yes, then a whole new problem comes up. To get a BDp or not. If I do get a BDp, then I need to change my crappy Sammy TV too. That will hurt my pocket:sad:
 
Try with another player OR sam player with other TV.
If in warrenty,then opt of calling service centre...
 
Buy from India's official online dealer!
Back
Top