• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Denon 791/1911 display issue

madhurvyas

New Member
Joined
Feb 18, 2011
Messages
54
Points
0
Location
Bikaner
Hi,

I have been using denon 791 which is similar to 1911 for last three years, last few days back it started giving me some problems, display on tv will go off after 15-20 mins, sound will still come, though when display goes off avr will pause for a second, then sound starts back but no display.
I'm using a htpc connected to avr which is connected to 42in plasma. Setup was working fine, havent done any changes to setup.
I tried connecting Ps3 to avr still same issue after 15-20 mins no display.

I feel either its heating issue, but its been running in same setup for very long.
Second though would be some internal IC has damaged.
 
SPONSORED ADS

SPONSORED ADS

mikehcm

Active Member
Joined
Oct 3, 2011
Messages
172
Points
28
Location
Chennai
looks to a trouble with HDMI board, better to look for qualified technician for help.
 

rayvonnee

Active Member
Joined
Dec 6, 2012
Messages
543
Points
43
Location
Kurla, Mumbai
Im too facing this issue with my denon x500 but it used to happen earlier now just the screen flickers once but there is no audio drop. Im blaming my hdmi cables currently as they are not very good ones just brought locally. Will try connecting directly and see if there is any issue.
 

madhurvyas

New Member
Joined
Feb 18, 2011
Messages
54
Points
0
Location
Bikaner
My cables are from DAC, and are pretty good. I also feel some component is damaged, or go for dual hdmi graphic card option, one for audio to avr other for display to tv. I dont have any denon repair guy nearby, probably I have to go to delhi.
 
SPONSORED ADS

Top