• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

How to make use of Wharf 9.2 speakers for both stereo and HT Setup? (as front)

Audiolab 6000CDT Dedicated CD Transport

demigod

Member
Joined
Dec 16, 2009
Messages
52
Points
8
Location
Pune
All, lt's been a while but now i'm back to the forum.

I have a pair of Wharf 9.2 book shelf speakers. I connected them to both Norge (for Stereo music setup) and Yamaha AVR for HT setup as front speakers.

There are 4 connectors in the speaker with a gold plated link between both +ves and -ves. So i used two connectors each for both Norge and Yamaha. I always made sure that not both the amps switched on. I was using it like this for a while.

But yesterday when Norge was playing, i suddenly saw the right channel was disconnected and only left was playing. Also i could smell something burning and switched off everything completely. I could see Norge was completely heated up. Even after few hours of cool off the right channel is not playing any more.

1. What could have happened to Norge? Is there a way to fix this? Currenly i'm in Malaysia so not really sure, how can i get this fixed? Any suggestions to fix/troubleshoot this myself?

2. What is the best way to connect common pair of speakers across the amps? Did i do something wrong?

Appreciate your inputs.

Thanks.
 
SPONSORED ADS

SPONSORED ADS

magma

Well-Known Member
Joined
Dec 6, 2008
Messages
2,701
Points
113
Location
Mumbai
safest way is to use a swticher

or use the the norge as a power and the yamaha as a pre - connect front speakers only to norge
 
SPONSORED ADS

Top