• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Norge 2060 amp - Four ports for each channel.

Audiolab 6000CDT Dedicated CD Transport

kapilcbe

New Member
Joined
Nov 15, 2013
Messages
4
Points
0
Location
India
I recently purchased a used pair of Wharfdale 10.2 speakers for 15k along with Norge 2060 amp for 3k. I think, I got a decent deal considering a new pair of Wharfdale 10.2 costs around 29k.
But I am confused about the connectors/output ports on the Norge amp. There are four output ports for each channel (or zone, as they call it). How am I supposed to connect the Speakers to the amp.





Is it correct what I have done? Or am I losing some output by not using the other two ports for each zone.
Please help guys.
 
Joined
Dec 17, 2012
Messages
79
Points
18
Location
Vadodara, Baroda
The 4 ports are for 2 pairs of speakers (4 nos.)

Since you have only 1 pair (2 nos) you can make all the connections to either A or B.

Say for e.g. let us connections are made only to A
Left Speaker - Connect the wire from red terminal of speaker to red terminal of amplifier and Black to Black terminal of amplifier
Right speaker - same as above

if you want to use both A & B (applicable only if you have 4 speakers - 2 pairs) follow the above procedure.
 

spirovious

Well-Known Member
Joined
Apr 10, 2008
Messages
12,353
Points
113
Location
Mumbai



Is it correct what I have done? Or am I losing some output by not using the other two ports for each zone.
Please help guys.
Looking at the image,you have connected wrongly.Either all wire should be connected to top row with correct +ve and _ve terminal of speakers or the row below(A or B).Press the A or B select button on amp accordingly.
Else you get sound from one speaker only.
 

kapilcbe

New Member
Joined
Nov 15, 2013
Messages
4
Points
0
Location
India
Thanks for the reply guys.
I am now using the ports from zone A to connect both the speakers. And now I am getting the stereo effect which was missing earlier.
So it means that zone A/B contains both the channels. And that my earlier connection meant I was using only one channel for both the speakers and each speaker was getting half of the power compared to current connection.
 

kapilcbe

New Member
Joined
Nov 15, 2013
Messages
4
Points
0
Location
India
There is so much difference in the sound after connecting them correctly. Earlier I was feeling let down by the setup, but not anymore (ignorant me)
Thanks a lot for the help everyone.
 

kapilcbe

New Member
Joined
Nov 15, 2013
Messages
4
Points
0
Location
India
Hi Murali,

This is my first serious speaker purchase. Before this, I knew only about aux and cheap 2.1 or 5.1 setups.
This setup is just two days old and I am already proud of it.
Thanks for the suggestion about the pre-amp. I will surely look into it. But before that, I have to search for what is pre-amp and how to bypass the internal amp of my Norge :)
 
Top