• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Please Help..Wharfedale Subwoofer SW 150 not working.

Wharfedale Evo 4.2

Subcenter2009

Active Member
Joined
Mar 9, 2009
Messages
157
Points
28
Location
Chennai
Dear Friends,
I live in Chennai...
My Wharfedale SW 150 sub is not working.
There is no sound at all from it.
The power light is working.
I need to know what could be wrong with it.
Could the coil have failed?
The Kevlar cone is in perfect condition.
What else could be wrong with it?

In case the speaker has failed, what do I do to repair/replace it?
Do I need a new woofer or can the old one be repaired?
I need the tight bass the original sub used to give me.
Can you guide me about replacement woofers and what brands?
Where in Chennai can I get it repaired?
I bought it from Pro musicals 10 years back but they don't deal with Hi Fi anymore...
Is Power electronics in Ritchie street a good place?
Remember, I desire the old quality of tight bass...
The old woofer cone is very very stiff and hence produces tight sub bass.
Is it worth repairing the sub?
Please guide me friends...
Yours,
Subcenter2009
 
Last edited:

Subcenter2009

Active Member
Joined
Mar 9, 2009
Messages
157
Points
28
Location
Chennai
Dear friends,
Just wanted to know..
Does Wharfedale have a service centre in Chennai?
Is there one in Mumbai?
How does one ship the heavy subwoofer to Mumbai just in case I don't find anyone here in Chennai?
Can fellow forum members name some places in Chennai that can repair this subwoofer?
Thanks,
Subcenter2009
 

JayaRaa

Active Member
Joined
Apr 14, 2015
Messages
835
Points
43
Location
India
call designer audio, their distributor - here is their info
Designer Audio India Pvt. Ltd.
Udyog Bhavan, Basement, W.H. Marg, Ballard Estate, Mumbai - 400038. India.
Tel: +91 22 22622839, 22622840, 22622841 Email: contact@designeraudio.in
* Office Timings: Mon-Fri 10:30am-6:30pm, Sat 10:30am-4:30pm, Sun closed.
 

Subcenter2009

Active Member
Joined
Mar 9, 2009
Messages
157
Points
28
Location
Chennai
Thank you for your quick response, Sir.
Other members, please feel free to guide me if you can on repair and service centers here in Chennai..
Thanking you,
Subcenter2009
 

elangoas

Well-Known Member
Joined
Nov 4, 2009
Messages
7,536
Points
113
Location
Madrasapattinam
Thank you for your quick response, Sir.
Other members, please feel free to guide me if you can on repair and service centers here in Chennai..
Thanking you,
Subcenter2009

MAX Home Theaters
Karpaga Vinayagar Koil Street, Alandur, Chennai, Tamil Nadu 600016
Contact person, Murugan # 97864 55577
(Landmark : Behind Le Royal Mridien)

Location on google maps : https://goo.gl/maps/dNLaFkLLfDD2

This is the authorised service for Taga Harmony products in Chennai, buy they also service other products..

You can tell him, that Elango from Tiruvallur referred for service.. I don't have an idea on how much he would charge for a service.. Get the rates cleared before you decide to drop the sub there..
 

efernand1

Well-Known Member
Joined
Jul 6, 2012
Messages
5,513
Points
113
Location
Mumbai
Possible amp circuit issue......maybe a fuse or dry solder...

Get it checked and ask for the estimate.....
 

grebe925

Member
Joined
Sep 7, 2010
Messages
75
Points
18
Location
bangalore
Dear Friends,
I live in Chennai...
My Wharfedale SW 150 sub is not working.
There is no sound at all from it.
The power light is working.
I need to know what could be wrong with it.
Could the coil have failed?
The Kevlar cone is in perfect condition.
What else could be wrong with it?

In case the speaker has failed, what do I do to repair/replace it?
Do I need a new woofer or can the old one be repaired?
I need the tight bass the original sub used to give me.
Can you guide me about replacement woofers and what brands?
Where in Chennai can I get it repaired?
I bought it from Pro musicals 10 years back but they don't deal with Hi Fi anymore...
Is Power electronics in Ritchie street a good place?
Remember, I desire the old quality of tight bass...
The old woofer cone is very very stiff and hence produces tight sub bass.
Is it worth repairing the sub?
Please guide me friends...
Yours,
Subcenter2009

Looks like it has a fuse in the circuit. Did you check it to see if it has blown? Also give a couple of cranks to the volume control and other knobs. I have a KEF sub-woofer about the same age and have to do that from time to time because the wiper contact in the pots does not complete the circuit due to contamination so there's no sound.
 
Last edited:

VSTEREO

Active Member
Joined
May 7, 2016
Messages
172
Points
28
Location
Chennai
Possible amp circuit issue......maybe a fuse or dry solder...

Get it checked and ask for the estimate.....

Yes, As efernand1 mentioned, please open and check the fuse and any visible damage (like burned resistor) before hitting service center.
 

spirovious

Well-Known Member
Joined
Apr 10, 2008
Messages
12,592
Points
113
Location
Mumbai
Looks like it has a fuse in the circuit. Did you check it to see if it has blown? Also give a couple of cranks to the volume control and other knobs. I have a KEF sub-woofer about the same age and have to do that from time to time because the wiper contact in the pots does not complete the circuit due to contamination so there's no sound.
He said that power light is on.Before opening sub,just change sw cable and see.
 

efernand1

Well-Known Member
Joined
Jul 6, 2012
Messages
5,513
Points
113
Location
Mumbai
Agree...

Possibly disconnect the sub cable from AVR....on the sub and keep the sub volume at half....tap with your fingers on the sub cable....does a thump sound come?

if yes then AVR settings needs to be checked for sub volume levels....bass management too...

if not then something has gone wrong on the sub amp plate board.....either fuse or components..
 

Subcenter2009

Active Member
Joined
Mar 9, 2009
Messages
157
Points
28
Location
Chennai
Wharfedale Diamond SW 150 sub has been repaired..Thanks everybody.

Dear friends,
My SW 150 Wharfedale diamond series subwoofer has just been repaired.
I got it serviced with Power Electronics near Ritchie street, Mount road, Chennai.
I spoke to Mr. Thankachan who ensured that they did a good job.
He is the brain behind the "Torvin" brand of Pro and HiFI gear, amps and speakers.
The woofer was fine, there was no dry soldering and the circuits were ok.
There was only a problem with a relay and a protection circuit.
I brought it home and couldn't wait to test it...
It sounded as good as new!
I now have to use it for a few days and see.
The work was completed in 4 days.
2 months guarantee on service.
No complaints.:clapping:
So, A big thank you to all of you who contributed to this post and helped me to make up my mind.
So, Thank you all once again...
Yours,
Subcenter2009:yahoo:
 
Last edited:
Top