• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Power dripping/flickering problem in Yamaha AS500

Home Theatre Systems

Ebenezer

Member
Joined
Feb 16, 2011
Messages
69
Points
8
Location
Chennai
Hi All,

I need a help. I have been using Yamaha AS500 amplifier for the last few years. At times the power LED light flickers and the amp's power drips continuously (i get click click sound continuously for some time) and then it remain stable (on). during the flickering which last far few seconds to 1 minute no sound comes out of amp. I dont know what could cause this. I checked for any amp/speaker/DAC cable shortage, everything seems to be right.

I have given it to Yamaha service center in Chennai, even they are unable to find out the reason for the problem. Anyone has faced this kind of problem before?

Would appreciate your help here.
 

Amitkg

Active Member
Joined
Jul 2, 2014
Messages
495
Points
43
Location
Agarpara, Kolkata
From symptom, I guess, it's because of power fluctuation, not necessarily of low-voltage problem. Take it to some place else, use it and see whether AS500 behaves in same manner or not. Also check the wall-socket.
 

Vinod.R

Well-Known Member
Joined
Dec 10, 2010
Messages
1,599
Points
113
Location
Thrissur, Kerala
As Amitkg has said above, it sounds like a low voltage when the power dips below safe levels for the amp to handle. Do you plug it directly to the wall socket or do you have some sort of CVT/power conditioner attached to it?
 

Ebenezer

Member
Joined
Feb 16, 2011
Messages
69
Points
8
Location
Chennai
Hello Amit & Vinod, thanks for your response. I connect my amp directly to wall socket. I have given it to service center. There also it dripps (without connecting any speakers to it) but the frequency is less compared to my home.

Do you think adding a voltage stabilizer could help resolve the problem??
 

Ebenezer

Member
Joined
Feb 16, 2011
Messages
69
Points
8
Location
Chennai
I asked the service person if there is any problem with the power supply unit of amp, he says there is no fault with power supply unit, the voltage is right. He assumes that there could be problem with the signal coming out of digital board... He is unsure about it. He is currently monitoring it and he said rarely he gets the flickering. Whereas at my home i was getting it quite frequently...
 

Ebenezer

Member
Joined
Feb 16, 2011
Messages
69
Points
8
Location
Chennai
Do anyone know good amplifier service center/contact person in Chennai who can fix this problem??
 
Top