• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Dolby Digital Plus question....

HiFiMART.com

Sandesh

Active Member
Joined
Mar 10, 2013
Messages
518
Points
28
Location
Bangalore
Hi guys can also help me? I don't seem to be getting any sound from the rear speakers in my surround sound on Netflix and Amazon, but the other three speakers work 2 loud speaker and centre in the 5.1 setup works fine. Im using my LG C9 smart Oled Tv. Ive connected the TV and AVR through an optical cable. I am using an old AVR Onkyo Tx-DS676 - https://www.cnet.com/products/onkyo-onkyo-tx-ds676/ , so ARC/HDMI is not possible with it. The signals I get are DTS decoder, Dolby Digital, Dolby Pro Logic. Is this happening because I don't have the Dolby Digital Plus on my AVR? If yes, besides buying another AVR, is there a device that I can connect to my AVR for this purpose?When I play youtube surround sound videos or use the Cd player on 5.1, my rear speakers work perfectly.

P:S- I am using an ULTRA HD account on Netflix
 

skumar

Active Member
Joined
Apr 2, 2009
Messages
630
Points
43
Location
Hyd, India
I don't seem to be getting any sound from the rear speakers in my surround sound on Netflix and Amazon, but the other three speakers work 2 loud speaker and centre in the 5.1 setup works fine.
Change the output on your TV to send DD via optical cable (this might be PCM now and optical can carry only 2.0 PCM at max or 5.1 DD).
When I play youtube surround sound videos or use the Cd player on 5.1, my rear speakers work perfectly.
Youtube provides 2.0 audio only for now. On AVR, input (CDP) may have been configured to use surround processor.
 

skumar

Active Member
Joined
Apr 2, 2009
Messages
630
Points
43
Location
Hyd, India
You need to go thru the instruction manual of your TV to configure optical out as DD (some where in sound/audio settings). Also, the same applies to AVR manual - you can check the signal being passed on the optical cable to AVR, if you know where to look for - whether it is DD 2.0/ DD 5.1 or PCM.
 

Vivek Rao

Active Member
Joined
Nov 19, 2009
Messages
189
Points
43
Location
bangalore
Hi guys can also help me? I don't seem to be getting any sound from the rear speakers in my surround sound on Netflix and Amazon, but the other three speakers work 2 loud speaker and centre in the 5.1 setup works fine. Im using my LG C9 smart Oled Tv. Ive connected the TV and AVR through an optical cable. I am using an old AVR Onkyo Tx-DS676 - https://www.cnet.com/products/onkyo-onkyo-tx-ds676/ , so ARC/HDMI is not possible with it. The signals I get are DTS decoder, Dolby Digital, Dolby Pro Logic. Is this happening because I don't have the Dolby Digital Plus on my AVR? If yes, besides buying another AVR, is there a device that I can connect to my AVR for this purpose?When I play youtube surround sound videos or use the Cd player on 5.1, my rear speakers work perfectly.

P:S- I am using an ULTRA HD account on Netflix
I too use a new LG tv (ULED and not OLED) with an old 5.1 Kenwood amplifer connected through the optical cable. I was able to get 5.1 by taking care of the following :
1. The TV gives option to use internal + optical speakers under the "speaker output" . Change this to ONLY optical.
2. After doing step 1 then go to the details section and under audio settings make sure that the optical setting has Auto selected and below this in the format section choose Dolby digitial.

once you do this setup then you do not have to come to the audio detail section everytime when you choose from hearing from TV or from your Onkyo. You would need to however keep toggling between "internal" and "optical" in the speaker settings. Cheers
 

Sandesh

Active Member
Joined
Mar 10, 2013
Messages
518
Points
28
Location
Bangalore
I too use a new LG tv (ULED and not OLED) with an old 5.1 Kenwood amplifer connected through the optical cable. I was able to get 5.1 by taking care of the following :
1. The TV gives option to use internal + optical speakers under the "speaker output" . Change this to ONLY optical.
2. After doing step 1 then go to the details section and under audio settings make sure that the optical setting has Auto selected and below this in the format section choose Dolby digitial.

once you do this setup then you do not have to come to the audio detail section everytime when you choose from hearing from TV or from your Onkyo. You would need to however keep toggling between "internal" and "optical" in the speaker settings. Cheers
I'll try it out today and let you know! Thanks a lot for the advice...
 

Sandesh

Active Member
Joined
Mar 10, 2013
Messages
518
Points
28
Location
Bangalore
I too use a new LG tv (ULED and not OLED) with an old 5.1 Kenwood amplifer connected through the optical cable. I was able to get 5.1 by taking care of the following :
1. The TV gives option to use internal + optical speakers under the "speaker output" . Change this to ONLY optical.
2. After doing step 1 then go to the details section and under audio settings make sure that the optical setting has Auto selected and below this in the format section choose Dolby digitial.

once you do this setup then you do not have to come to the audio detail section everytime when you choose from hearing from TV or from your Onkyo. You would need to however keep toggling between "internal" and "optical" in the speaker settings. Cheers
Finally figured out! Besides the above I changed my settings on my amp to 5.1, instead of Dolby prologic and it all worked out fine!
 
Top