Optomo HD70 Projector Service

Home Theatre Systems

krishna

New Member
Joined
Jun 7, 2008
Messages
5
Points
0
Location
Bangalore
Hi,
I have a 720p DSP Projector, Optoma HD70, bought in circuit city (US) and brought to India. I was using it without problem for the last 6 months (200+ hours). Now i have am facing a problem where the screen has Greenish flickers after running the projector for 30 mins or so (sometime sooner). If allowed to continue the flickers becomes permanent.
I connect the projector to my PC Video Card. I know the problem is in the projector (and not the Video card) because even while i disconnect the VGA cable to my card, i still see this Greenish screen.

I have blown air though the air ducts to see if the dust has caused this failure, but no luck :-(

Has anyone seen such a problem on your projector? Does anyone know if there is someone in India who services Optoma projectors?

Thanks in advance
 

krishna

New Member
Joined
Jun 7, 2008
Messages
5
Points
0
Location
Bangalore
Thanks for the help Manic.
I did some investigation myself and found that the problem was due to the fact that the projector was over heating in 30 mins causing it to shut down.
I have now fitted a fan (wall mounted fan) near the projector air inlet and that appears to have fixed the problem.
Thanks for the help anyway.
 

rshri

Active Member
Joined
Jul 15, 2008
Messages
439
Points
43
Location
New Delhi
Thanks for the help Manic.
I did some investigation myself and found that the problem was due to the fact that the projector was over heating in 30 mins causing it to shut down.
I have now fitted a fan (wall mounted fan) near the projector air inlet and that appears to have fixed the problem.
Thanks for the help anyway.

Even Optoma HD65 is known to become very hot. Hats off for being able to detect the real problem!! Good investigation!!
 
Top