• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Problem -with HDMI switcher

Rega

muks1224

Member
Joined
Aug 16, 2010
Messages
109
Points
18
Location
chennai
Hi!

Iam using a 4 port HDMI switcher with 2 out ports connected through a AV rcvr. Iam facing a peculiar problem .When a a video is playing either on my tv or projector ,whenever any power switch is used at any where in my home is used ,the video seems to loose sync and then it comes back it happen both on my tv as well as projector.iam using a stabilised power .In fact i have changed the HDMI switcher to eliminate any malfunction on the previous unit, problem persists.Any suggestions am i missing something http://www.hifivision.com/images/icons/icon5.gif.

thanks
 
SPONSORED ADS

SPONSORED ADS

arunsankar

New Member
Joined
Sep 17, 2010
Messages
79
Points
0
Location
Kochi
I had similar issues with my LED TV. Instead of any switch, for me the Fan regulators were creating issues. I changed all HDMI cables used to high quality ones and the issue resolved.
 

muks1224

Member
Joined
Aug 16, 2010
Messages
109
Points
18
Location
chennai
I had similar issues with my LED TV. Instead of any switch, for me the Fan regulators were creating issues. I changed all HDMI cables used to high quality ones and the issue resolved.
Arunshankar,

Thanks can you tell which brand of HDMI cable did you use

mukun
 

Hari Iyer

Well-Known Member
Joined
Feb 8, 2010
Messages
2,888
Points
113
Location
Mumbai
Try also using a ferrite core in these cables to avoid noise. Select cables with build-in ferrite cores and ask for one for reducing spurious RF / EMI noise.
 
SPONSORED ADS

Top