• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Video flickering and freezing after power on - SONY AV Receiver STRDH550

Wharfedale Evo 4.2

ngnp

New Member
Joined
Aug 29, 2018
Messages
14
Points
1
Location
chennai
Have Sony STRDH550 AV receiver.

My connection : Videocon D2H -> Sony AV receiver ( SAT/CATV : Hdmi port ) -> TV ( all via HDMI cable )

When I power on the AV receiver, the video flickers and the picture freezes.

Then I entered home menu of the receiver -> Selected SAT/CATV of the menu.
Strange -> Flickering / freezing stops and video runs smoothly then after

This happens every time when I power on the AV receiver.
Once on, it will flicker. I have to enter home menu of the receiver & select SAT/CATV to make it stop.

What could be the reason?

If it is hardware related issue, I feel the flicker/freeze should be present continuously.
In may case, it disappears when I chose SAT/CATV menu in receiver -> Can it be a hardware issue?


(or) Could it be like this :

After power on the AV receiver, the HDMI cable ( though mentioned high speed ) connected between AV receiver & TV not able to handle the color depth of the AV receiver and hence the video flickers and freezes

When I chose SAT/CATV menu in AV receiver, the video of set top box ( normal HD ) outputted by the AV receiver was manageable by the HDMI cable & hence there is no flickering / freezing then after.

Will it solve the issue? ( After power on, video is smooth )


Like to have some solution
 

newlash09

Well-Known Member
Joined
Dec 17, 2014
Messages
1,053
Points
113
Location
hyderabad
Have Sony STRDH550 AV receiver.

My connection : Videocon D2H -> Sony AV receiver ( SAT/CATV : Hdmi port ) -> TV ( all via HDMI cable )

When I power on the AV receiver, the video flickers and the picture freezes.

Then I entered home menu of the receiver -> Selected SAT/CATV of the menu.
Strange -> Flickering / freezing stops and video runs smoothly then after

This happens every time when I power on the AV receiver.
Once on, it will flicker. I have to enter home menu of the receiver & select SAT/CATV to make it stop.

What could be the reason?

If it is hardware related issue, I feel the flicker/freeze should be present continuously.
In may case, it disappears when I chose SAT/CATV menu in receiver -> Can it be a hardware issue?


(or) Could it be like this :

After power on the AV receiver, the HDMI cable ( though mentioned high speed ) connected between AV receiver & TV not able to handle the color depth of the AV receiver and hence the video flickers and freezes

When I chose SAT/CATV menu in AV receiver, the video of set top box ( normal HD ) outputted by the AV receiver was manageable by the HDMI cable & hence there is no flickering / freezing then after.

Will it solve the issue? ( After power on, video is smooth )


Like to have some solution

Hi ngnp....

Do you have anything that says "hdmi control enabled" in the video or avr settings by any chance. And is the D2H the only source connected to the avr.
 
Top