• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Cause of image corruption? Sony KDL40X2000U

Wharfedale Linton Heritage Speakers

iaeon

New Member
Joined
Jan 21, 2015
Messages
1
Points
0
Location
London
From October 2006 my KDL40X2000U LCD TV has served well. It continues to do so when in a good mood. Sadly it's mood is now tetchy. Generally a few minutes after switching on it will start corrupting images with certain luma levels getting 'flattened' into lighter tones (looking somewhat posterized). Leave it for a bit and it may behave again, or not...

The question is: Any ideas of the cause? Could it be dodgy connections on the boards / cables? Or is more likely to be component failure?

If the former I might be able to clean it. If the latter depending on the component it may I guess not be economically appropriate to repair...

Ideas?

IMG_4401.jpg
 

firearm12

Well-Known Member
Joined
Sep 24, 2014
Messages
965
Points
93
Location
noida
You said it stats misbehaving a few minutes after switching on. That makes me believe its not dodgy connections but a component failure. Maybe some component starts failing once it gets heated up. Just my two cents.

I have had cases where I have used hair dryers to startup my latptop, it wont start until you give its chip a hot blow. Also have had a nokia mobile which turned itself off in very hot summers and will only startup after I had put it in freezer for 10 mins. Unbilievable but its true. :)
 
Top