• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Problem with marantz CD 63 mkii KI version

Audiolab 6000A Amplifier

Aldrin

Member
Joined
Nov 24, 2016
Messages
56
Points
18
Location
Nagercoil
I am having a marantz CD 63 mkii ki CD player , which is having some issues in reading disc. Changed the laser but no use, same issue continues. In service mode it's showing error 10, which refers to radial errror. Anybody have any idea regarding that radial error?
Also the player is randomly detecting CDs and playing. But once it detects it plays without fault.
In service mode also it's playing CDs.
Is it good to play cds in service mode?
Kindly share ur ideas.
Thanks
Aldrin
 
SPONSORED ADS

SPONSORED ADS

mpasanthosh

Active Member
Joined
Oct 23, 2015
Messages
101
Points
28
Location
Salem
I am having a marantz CD 63 mkii ki CD player , which is having some issues in reading disc. Changed the laser but no use, same issue continues. In service mode it's showing error 10, which refers to radial errror. Anybody have any idea regarding that radial error?
Also the player is randomly detecting CDs and playing. But once it detects it plays without fault.
In service mode also it's playing CDs.
Is it good to play cds in service mode?
Kindly share ur ideas.
Thanks
Aldrin
Sometimes a adjustment is required for laser current .
This is controlled by a potentiometer, suggest to take it to a good technician to get this checked .
You would need to check for lens focus offset as well, if in case a potentiometer is present for this particular model.
 
SPONSORED ADS

Top