• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

subwoofer popping sound??

Wharfedale Diamond 11.1 & 11.2 Speakers

manu4panjab

New Member
Joined
Aug 28, 2008
Messages
1,858
Points
0
Location
in my house..,
brothers today my polk dsw pro 600 produce popping sound when i turn on onk 807 it just pop for fraction of second just one pop and when i increase the volume like i normally use -30 db when i raise it to like -20db or up pro 600 starts popping on bass heavy scenes does this means i'm listeening at higher volumes and my sub can't catch with higher volumes but my olk polk psw 125 has no problem even when i'm driving it at -5db to 0db is my pro 600 damage but why is this happening is there problem with sub or what please reply i'm worried :sad:
 
Last edited:

qoolss

New Member
Joined
Oct 21, 2007
Messages
71
Points
0
Manu,

sorry to hear that. normally if it was a loud pop once, and then ever after it does on heavy bass sound then most likely your sub is gone. however, i could be wrong. check the gain of your sub if its half or more then please reduce it to 40% only and not more. the chances are if you keep the gain higher then it can blow up. also, if possible take it back to the guy you bought it from and say its making poping sound and please change it.

i hope it helps.

cheers,

Swatantra
 

manu4panjab

New Member
Joined
Aug 28, 2008
Messages
1,858
Points
0
Location
in my house..,
Manu,

sorry to hear that. normally if it was a loud pop once, and then ever after it does on heavy bass sound then most likely your sub is gone. however, i could be wrong. check the gain of your sub if its half or more then please reduce it to 40% only and not more. the chances are if you keep the gain higher then it can blow up. also, if possible take it back to the guy you bought it from and say its making poping sound and please change it.

i hope it helps.

cheers,

Swatantra

thanks bro for reply sub gain is at around only 30% and sub starts popping when i raise the volume not on normal listening levels so is the sub gone
 

S.P.KRISHNA

Active Member
Joined
Oct 5, 2009
Messages
337
Points
28
Location
HYDERABAD
thanks bro for reply sub gain is at around only 30% and sub starts popping when i raise the volume not on normal listening levels so is the sub gone

My advise is to take it to a nearby show room where A.V.receivers or H.T demos are shown and play it on the available receivers and then only you can find whats wrong with it.

Regards
 

manu4panjab

New Member
Joined
Aug 28, 2008
Messages
1,858
Points
0
Location
in my house..,
i just cure the problem :yahoo: actually i was playing sub very hard i set it at -0.5 db and others are around -7db etc ect but when again i set sub volume knob to half and i then run audyssey again and it set my subwoofer now -10db and others at -7db etc etc and no popping sound at all even at reference volume level of avr 0db :D
 
Top