• Hello and Welcome to HiFiVision.com - an online community for the home entertainment and tech enthusiasts!

    If you would like to ask a question, participate in a discussion and view attachments please Register yourself.

Yamaha Stereo receiver tripping

Luxman Amplifiers India

vj_box

Active Member
Joined
Jul 14, 2008
Messages
562
Points
43
Location
Madras
Hey guys, I recently got hold of a old yamaha stereo receiver with beautiful sound signature. The unit began to trip or switch off instantly as it is turned on and goes into stand mode where you still see the light indicator. I got the unit serviced from the local yamaha service center and the guy blamed some dry solders which fixed the issue for a while. But the issue has resurfaced again and the unit is tripping whenever I turn it on.

What could be the issue? Do I take it back to the service center again and have the guy fix it properly?

Thanks!
 

MaSh

Well-Known Member
Joined
Oct 12, 2012
Messages
3,641
Points
113
Location
Bangalore
Hey guys, I recently got hold of a old yamaha stereo receiver with beautiful sound signature. The unit began to trip or switch off instantly as it is turned on and goes into stand mode where you still see the light indicator. I got the unit serviced from the local yamaha service center and the guy blamed some dry solders which fixed the issue for a while. But the issue has resurfaced again and the unit is tripping whenever I turn it on.

What could be the issue? Do I take it back to the service center again and have the guy fix it properly?

Thanks!

Does this happen with speakers connected? Did you try to change sources? Does it switch off immediately for after a couple of minutes?
 

Audio_Freek

Well-Known Member
Joined
Jul 19, 2012
Messages
1,109
Points
83
Location
Bangalore
Its a Power issue(Transformer).I had same situation with a Yamaha AV and in Chennai they charged me 2.5K for complete Transformer replacement.

How much did they charge for the service?
 

Srinath_seshadri

New Member
Joined
Dec 1, 2012
Messages
384
Points
0
Location
Charlotte NC, USA
What model old yamaha amp ?
The 40 series has had issues 640, 840, 1040 etc were issue prone but their issue was the main power amp chip which was not available.

I have a R2000 with a similar issue, but it has discrete chips for pre driver etc etc.
Cool.
Srinath.
 

alok_student2000

New Member
Joined
Mar 26, 2012
Messages
39
Points
0
Location
Delhi
Y not u arrange for good quality solder and Do it your self.. it'll save your costs if dry joints is the only issue... just get a pointed tip iron and 0.5mm solder wire - rosin core one.. 50 grams..
 
Last edited:
Top